Help

Change Api Key to PAT

701 2
cancel
Showing results for 
Search instead for 
Did you mean: 
Gordon_Szulc
5 - Automation Enthusiast
5 - Automation Enthusiast

Good day all,

Over the past year I have moved from the old API key to PAT successfully accessing the base from third party apps (in particular filmmaker & MAKE ) just needing the API key swapping with the new PAT ... all good.

I have a couple of scripts that work on the base in question which effectively moves the records to another Archive base ... this has been working great for years. until now that I have tried to change the API key to the PAT.  It just refuses to create the record in the Archive base, Make and Filemaker both can

Any assistance would be very much appreciated as I cannot see what is wrong the PAT has full access to all scopes and I'm baffled and have even tried a new PAT code

Regards

Gordon

2 Replies 2
GavinA
8 - Airtable Astronomer
8 - Airtable Astronomer

Hey @Gordon_Szulc - have you made sure that the PAT you are using has the permission data.records:write permission enabled? 

When creating a PAT, you need to select all the scopes you need. The old API keys worked for everything, but with PAT you need to set scopes according to what you are using it for.

I have written a brief guide here.

HI,

Thank you for the quick response and the guide is handy.

I have looked and all was correct ... EXCEPT ... I had given permission to access the wrong base 🤦🏻‍♂️

Again ... Thanks & Regards

Gordon