Help

Do not return { success: true } after webhook success

287 7
cancel
Showing results for 
Search instead for 
Did you mean: 

Some applications like Twilio ask for a webhook where they can POST responses. Therefore Airtable is a good candidate for such integration.

However, Airtable always return { success: true } after the webhook succeeds, which triggers an error on Twilio:

Invalid Content-Type: application/json; charset=utf-8 supplied

Is there a way to prevent Airtable from returning such response? I’ve found this topic already Silencing webhook received responses but no solution was provided.

Thanks in advance!

7 Replies 7

Hey Rafael - This is not currently possible but I totally I agree it would be useful to be able to customize the response thereby allowing more services to integrate with Airtable through the Automations incoming webhook triggers.


Out of curiosity, which part of Twilio are you trying to integrate with the webhook trigger? I have had success receiving webhook payloads coming from Twilio upon a SMS being sent to my number; configuration screenshot below :point_down:

Screen Shot 2022-05-21 at 2.39.00 PM

Hi Mark, thanks for your prompt reply.

It is the Messaging Service, as you can see below.

Screenshot-20220521164705-1160x664

So there’s currently no workaround? The integration works fine, but Twilio raises an error, which is very unfortunate as it will bloat my application with non-applicable errors and increase the likelihood that I miss a real error.

Ah, I see. And yes, to confirm, there is no way to customize or “silence” the JSON returned by the incoming webhook trigger.

If you email support@airtable.com and mention your feedback, the team can make sure it is properly routed!

In the meantime: I had this same problem, and I had to use Make.com to return a silent response to Twilio.

Make offers full integration with Airtable, and they offer a customizable “webhook response” module:

Well, there is, but it defeats the entire purpose of an elegant webhook architecture. Make (as @ScottWorld points out) can serve as a proxy buffer and a proxy is the only approach I’m aware of that will help with your Twilio integration. I tend to proxy these types of issues with Autocode or Firebase Cloud Functions.

By the way, I forgot to include a screenshot of how to set this up in Make.com. It’s very easy:

Screen Shot 2022-05-22 at 10.20.28 AM

Yes, you’re right. I ended up setting up an endpoint in my web server that will listen to Twilio’s webhook and then make the request to Airtable, returning an empty response.

As you said, kind of defeats the purpose of a no-code solution, but it works for now. I do hope that Airtable keeps improving its webhook functionality, which is already great but could be better with simple tweaks.

Thank you all.