Help

Upcoming database upgrades. to improve our reliability at 03:30 UTC on Feb. 25 / 7:30pm PT on Feb. 24. Some users may briefly experience slow load times or error messages. Learn more here

Get records by view, but records with wrong order are returned

Topic Labels: API
Solved
Jump to Solution
796 5
cancel
Showing results for 
Search instead for 
Did you mean: 

I use the following request to get list of records by view.
In this view, records are sorted by id DESC.
But the API returned list of records, which are sorted by id ASC
https://api.airtable.com/v0/mybasekey/mytable?api_key=my_key&view=my_view

This problem just happened in today.

Please help me to resolve this problem.

1 Solution

Accepted Solutions

Hi everyone, this should now be resolved. We detected the issue and made the fix on April 12, 2021. Thank you for the reports, and please let us know if you continue to see issues here.

Thanks,
Richard

See Solution in Thread

5 Replies 5

We, here, have the same problem. Urgent situation.

Hi there,

I can support what has been flagged above - I have the same issue. Please advise on a solution - this is REALLY important for our users considering that some apps are built on data viewer based on Airtable. Thanks!

Hi there, I think this issue arose earlier today. Just like everyone else this is super urgent… Very unexpected. Did anyone find a fix for this?

  • Dirty Fix:
    1. Create a new column, name it “Order Name” or something like that
    2. Sort the view into desired order
    3. Change the column to AutoNumber
    4. Now you can sort the view by the AutoNumber through the API
    5. This is obviously not a long-term fix and not scalable, but might address some people’s issues
  • This seems to be a core Airtable API issue.
  • The API returns records by a record’s created_date regardless of the View’s sorting order.
  • Filtering by view still works (only items visible in the View will appear in the data)
  • Using ‘sort’ with the API still works, meaning we can still sort by Asc / Desc

Hi everyone, this should now be resolved. We detected the issue and made the fix on April 12, 2021. Thank you for the reports, and please let us know if you continue to see issues here.

Thanks,
Richard