Help

Welcome to the Airtable Community! If you're new here, check out our Getting Started area to get the most out of your community experience.

Ceiling Function not rounding to 0.25

Topic Labels: Formulas
3048 5
cancel
Showing results for 
Search instead for 
Did you mean: 

I’m trying to use the Ceiling function to round a function result up to the nearest quarter, so 0.25. But my results are only rounding to the next 0.10.

How do I get it to always round up to the nearest .25, .50, .75, .00? It works like this in Excel but can’t seem to get it to work in airtable.

5 Replies 5

I’m seeing similar odd results. Some ceiling values work fine, while others don’t:

Screen Shot 2019-02-14 at 6.48.48 PM.png

Looks like it’s time for a bug report!

@Jesse_Poteet I received a reply from support. They’ve logged it to fix, and passed along this workaround that appears to do the trick for now:

CEILING(value/significance)*significance

Here’s an example that I ran to confirm, using this formula:

CEILING(value/0.25)*0.25

24%20PM

@Justin_Barrett hanks man. Yeah they had sent me the same fix so I’ve been using that and it’s working fine. They said back in August that it was reported and being worked on, but I guess not haha.

Finally needed to use the Ceiling function for the first time in Airtable today.
I can confirm that this still does not operate in the same way as it does in Excel for example.

The workaround shared here in this topic helped me to get it working as intended.

Just wanted to provide an update with this information. :grinning:

Hey Justin!

Just found your ancient post about the workaround concerning the CEILING() function. After I ran into the same problem I wanted to let you know that this bug is still there…

Kind regards
Michael