Help

How can i use the formula field in my calendar ?

Topic Labels: Formulas
Solved
Jump to Solution
1133 3
cancel
Showing results for 
Search instead for 
Did you mean: 
kbellerive
4 - Data Explorer
4 - Data Explorer
Hi, 
 
In my database I have several fields that are calculated automatically with a formula, but I want some of these important date in a calendar.  But the Calendar only allows me to use a Date Field, how can I "force" the calendar to take the formula date ?
 
This is my formula field
DATETIME_FORMAT(DATEADD({Date de départ}, -60,'day'),'DD-MMMM-YYYY')
 
Thanks for your help !
1 Solution

Accepted Solutions
kuovonne
18 - Pluto
18 - Pluto

You discovered that you needed to remove the DATETIME_FORMAT() from you formula to get Airtable to recognize the value as a date because DATETIME_FORMAT() was converting your date to a text string. To turn off the time from your formula, you should remove the format text string (because it isn’t doing anything) and instead use the formatting options in the format tab of the field configuration screen. You may need to tell the format options to use the same time zone for everyone. 

As for getting multiple dates to show up in different colors, each date should be in its own record and then you can use record coloring. If you want to use multiple dates in the same record, you can use one date as the start date and the other date as the end date, but you cannot get different colors for the range. 

See Solution in Thread

3 Replies 3
kbellerive
4 - Data Explorer
4 - Data Explorer

With this formula I got my date in calendar.. but a time appear.. how can I remove time ?

DATEADD({Date de départ},-60,'days','DD-MMMM-YYYY')
 
And.. how can I had a different color for my date, exemple
I want my shipping date in blue and my Send the email to my customer 10 days after the shipping date ?
kbellerive_0-1676738416396.png

 

kuovonne
18 - Pluto
18 - Pluto

You discovered that you needed to remove the DATETIME_FORMAT() from you formula to get Airtable to recognize the value as a date because DATETIME_FORMAT() was converting your date to a text string. To turn off the time from your formula, you should remove the format text string (because it isn’t doing anything) and instead use the formatting options in the format tab of the field configuration screen. You may need to tell the format options to use the same time zone for everyone. 

As for getting multiple dates to show up in different colors, each date should be in its own record and then you can use record coloring. If you want to use multiple dates in the same record, you can use one date as the start date and the other date as the end date, but you cannot get different colors for the range. 

Thanks a lot ! 🙂 i'll try this