One form prefills, the other doesn't

Topic Labels: Formulas
450 1
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer

Hey, everyone! I’m having a really tough time tracking down the issue here. I have two forms, both of which have a field that I’d like prefilled. The facts are:

  • 2 tables: (Companies, Vehicles).
  • Entries in Vehicles are linked to a Company.
  • Each company has a gallery view, filtered to only show vehicles in that company.
  • The primary unique field in Vehicles is the VIN.
  • 2 forms, 1 for each of 2 unique companies, and the field names are the same on each form.
  • The VIN field on the form is linked to the gallery of the respective company, thereby constraining to only those company’s vehicle’s VINs to be selectable.

When I fire up form 1 for company 1, no problem! The VIN is pre-selected without issue and works exactly as described in link_records_form_demo - airtable. No issues whatsoever.

When I fire up form 2 for company 2, the VIN is never preselected, no matter what I seem to do.

I’ve tried the troubleshooting steps listed here: Prefill not working - #2 by ScottWorld

  • Change your primary field values so that every record is unique: double & triple checked this, all records have a unique VIN
  • Prefill using the record id of the desired record, instead of the primary field value: tried this as well, switching from VIN to the actual record via RECORD_ID() – the result is that the 1st form continues to work, and the 2nd form continues to fail.

I feel like I am missing some larger issue, like “Oh sorry that’s a paid feature, you can only prefill 1 form” or something like that…

Any ideas?

1 Reply 1
8 - Airtable Astronomer
8 - Airtable Astronomer

I don’t see there being an issue with more than one prefilled form.

If you are passing multiple parameters make sure it has “prefill_” before each like below


You can use the field ids instead of the name of the field as well.

If you have spaces or other characters that need to be encoded be sure to use ENCODE_URL_COMPONENT.

Otherwise if you could share your formula that could help with suggestions.