Help

Re: Testing for non-BLANK returns incorrect result

Solved
Jump to Solution
536 0
cancel
Showing results for 
Search instead for 
Did you mean: 
Karl_at_Easy_La
6 - Interface Innovator
6 - Interface Innovator

I just realised this simple formula, on most fields does not work . Test was done on a Single-Line field.

 

IF(test1 != BLANK(), "Not Blank""Blank")
 
This will always return "Not Blank".  A workaround seems to be to do the below:
 
IF(Not(test1 = BLANK()), "Not Blank""Blank")
 
Any idea why this is so? Or is there a simpler work to check for 'Not Blank/Empty'?
1 Solution

Accepted Solutions
Sho
11 - Venus
11 - Venus

In formula fields, I want the formula to be simple, so this is how I do my field checks.

IF({test1}, "Not Blank", "Blank")
IF(NOT({test1}), "Blank", "Not Blank")

See Solution in Thread

5 Replies 5
dilipborad
8 - Airtable Astronomer
8 - Airtable Astronomer

Hello @Karl_at_Easy_La 

I think this will be a basic formula for it.

IF(Name=BLANK(), "Blank", "Not Blank")

Check the Image as well.

dilipborad_0-1703853769808.png

I hope it helps.

👍

 

Sho
11 - Venus
11 - Venus

In formula fields, I want the formula to be simple, so this is how I do my field checks.

IF({test1}, "Not Blank", "Blank")
IF(NOT({test1}), "Blank", "Not Blank")

You can also do  

IF(Name, 'Not Blank')

the default for third IF parameter is blank value, so it just output nothing when {Name} is empty. For one word field names figure brackets can be omitted.

Karl_at_Easy_La
6 - Interface Innovator
6 - Interface Innovator

I just realised the issue is with Lookup-type fields that give the most problems.  For those, = Blank() doesn't work as expected.  I'll use one of these proposed solutions, thanks!

You can experience problems using other functions with Lookup-type fields. To prevent it, convert array to string by adding empty string. Instead of {Field} use CONCATENATE({Field}) or ""&{Field}