Help

Attachments No Longer Show Previews

2412 7
cancel
Showing results for 
Search instead for 
Did you mean: 
Justin_E
5 - Automation Enthusiast
5 - Automation Enthusiast

Hello, my workflow uses Integromat to create new records on Airtable. I have an attachment field, to which PDFS are uploaded to.

Up until February 9th, a thumbnail / preview of the attachment was always displayed in my table. However, since the 9th, both the thumbnail and preview of the attachments always show as a generic document icon. I have to click the attachment to actually view it in full.

Was there some change that makes previews & thumbnails no longer available as of Feb 9th? All the records prior to the 9th still have working previews in my base. Is there something I can do to get this feature back with the more recent records?

7 Replies 7

Do you get thumbnails when you manually attach a document?

Can you ensure that integromat is not modifying the file type?

Thanks for the response. When I manually upload a PDF, I am getting the same result.

Just to clarify - it’s the thumbnails that no longer show up. When I click on the document icon, the preview window does open up with the PDF and I can view it just fine. But the thumbnails are just the generic icon now. I assume Airtable changed something and no longer will display thumbnails of PDFs, but I would like to get confirmation of that.

When I manually upload PDF I get the thumbnail

Capture

See screenshot, one jpeg and one PDF both show the thumbnail. Have you tried a different browser?

Hmm, curious. I have - I’ve tried Safari & Firefox on Mac and Edge on Windows. Same thing on all.

And actually the same on the iOS app. I wonder if there is a limit on PDF thumbnails or something. I do have several thousand of them (but nowhere close to the attachment or record limits…)

Hi @Justin_E I have the same issue - I also have thousands of PDF attachments in my base.

My most recent PDF with a successfully generated thumbnail is timestamped 5 Jan 2022 5:10 AM UTC.

The next PDF uploaded to my base is timestamped 5 Jan 2022 5:35 AM UTC, and it displays a generic document icon.

Possibly related, the preview for these files in Airtable no longer works for me. The viewer pane loads, but the file does not appear. Even my older uploaded files, where thumbnails exist, will not load in the file viewer.

I suspect that this could be an Airtable limitation. I’ve been using Airtable to serve thumbnail images to an external app, despite the official warning that this is not officially supported and will be subject to arbitrary changes - see comments in this discussion.

Maybe this promised/pre-warned change has now finally occurred?

yumenbionics
4 - Data Explorer
4 - Data Explorer

I seem to have the same problem with newly added photo's. PNG and Jpg. I am using a paid base and there is nothing special going on. There are only a view tables en records and no complicated integrations...

JLindem
6 - Interface Innovator
6 - Interface Innovator

I encountered the same issue, using Dropbox and Make (formerly Integromat) to upload images automatically to an attachment field in Airtable. I solved the issue, and it might work for you too.
Solution