Help

Re: Attachments uploaded via API vanish within seconds

2443 0
cancel
Showing results for 
Search instead for 
Did you mean: 
Sales_Asian_Dri
4 - Data Explorer
4 - Data Explorer

Hi,
I am having a problem using Integromat to upload my email attachments to Airtable.
My process is to save attachments in Drive > Generate a direct download link (double checked that it works without requiring any login) > save all attachments in an array (multiple attachments) > upload the entire array to Airtable.

I also get the files uploaded to Airtable as seen on my Airtable base. But within seconds, all the files vanish. I am at the end of my wits trying to figure out the problem. My email is a Google Workspace account, and I am currently trying out the Pro plan of Airtable.

Also, the first few records uploaded using Zapier are still there. But Integromat uploads keep on disappearing.

2020-12-09 01_12_37-Email tracker_ Table 1 - Airtable and 23 more pages - Personal - Microsoft​ Edge

Please help!

14 Replies 14

This is the understatement of the year.

Theo_Field
6 - Interface Innovator
6 - Interface Innovator

Looks like my vanishing PDFs are back… All was working as expected for about 2 weeks and now I am having the same issues, it is extremely frustrating.

I have reached out to Support @Jason, however I agree with Bill, this must be sorted - it is clearly a bug with the API as it works perfectly for periods of times and then has issues.

As predicted and experienced by countless users including @JN_tp.

Robert_Andrews
6 - Interface Innovator
6 - Interface Innovator

I'm finding this now via Integromat/Make - uploads from Google Drive create a proto-file that has no content and immediately disappears.

I've used the same Google Drive actions as @ScottWorld - ie to generate an openly-available web share link. I've confirmed that this link does download the file.

But, when inserted to Airtable, it basically doesn't get added.

@Robert_Andrews It should work. You have to set the permissions properly when uploading the file. Please post your problem in my forums at TableForums.com, and the Make.com experts will help you out!