Chrome thinks every field is a password field and offers to create or save the password

Topic Labels: Data
17723 60
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer

Chrome has started thinking every field in Airtable is a password field and pops up the 'Do you want to save this password?' after I finish typing in any field. It is very annoying!

It is also preventing me from choosing a date in a date field because it pops up the 'create a strong password' right on top of the calendar and I can't click on anything!

I've tried Googling for instructions for how to block the password autofill/offer to save on just one site, but can't find instructions exactly. 

Is anyone else having this issue? As far as I know, I didn't change anything about Chrome, this just started happening. 

60 Replies 60

This didn't work for me. Instead it just crashed / reset all my chrome browsers and some of my apps and then continued to ask me for the password. So don't recommend the EXPERIMENTS disable solution.

4 - Data Explorer
4 - Data Explorer

The best solution I found for now if you use Airtable heavily is turning off Chrome offering to save passwords:

1. Go to your chrome passwords manager:

2. Click the settings cog.

3. Turn off "Offer to Save Passwords"

Obviously this affects your future ability to save passwords but you can turn it back on once you're done with Airtable, or keep it off while the Airtable team fixes.

4 - Data Explorer
4 - Data Explorer

did not work for me either!

This worked perfectly for me. Thanks!

5 - Automation Enthusiast
5 - Automation Enthusiast

This is great - worked for me without having to turn off Google's password saving function (which is really useful, usually). Thanks! 

Airtable Employee
Airtable Employee

Hey all, we've made a few fixes to help stop this from happening.

If you still see this issue happening, please update Chrome to the latest version.

If after updating Chrome you still see this problem, please help us keep investigating by telling us:

  1. What version of Chrome you are using
  2. What part of the product you are using (e.g. Grid view, not in an Interface)
  3. What input fields the autofill is mistakenly appearing in

We're sorry about this annoying issue - we'll keep trying to fix it!

This issue appears to now be fully resolved for me [using Chrome Version 119.0.6045.123 (Official Build) (64-bit) on Windows]!  YAY!!!  Thanks David and the AirTable team!

This just started occurring again today. It was fixed until now. I also wanted to mention that our GM uses Safari on a Mac and experiencing the same issue. 😞 Bummer

  1. Versión 120.0.6099.109 (Build oficial) (arm64)
  2. Grid view
  3. Multiple select, but not only

@Samir_Ghosh I already reported this but the issue has returned as of about a month ago. It's persistent and happens many many times a day. It was fixed for a short while when you reported this but this is SUPER frustrating and in the way of our every day work. Please advise.