Help

Welcome to the Airtable Community! If you're new here, check out our Getting Started area to get the most out of your community experience.

Conditional Form by Read only linked fields

845 3
cancel
Showing results for 
Search instead for 
Did you mean: 

Hi everyone i need help on a form View.
I’m trying to build a form with field conditionned by read only field.
But the form don’t (White page) when i put the following condition (when i delete the condition, it appears !) ! 1|700x374
Have you seen something like this before ?
Thx !!

Polo

3 Replies 3

Hi @Paul_de_Leiris and welcome to the community!

You can’t add non input fields (eg lookups, formula fields, …) in a form. This has been a request on this forum since 2016 I noticed.

Hi Data baser ! Thx !

Here some more infos :

The form i want to make is :

1/ Ask people to chosse their name in a list

2/ Let them choose in 4 other fields to meet someone from a linked field.

  • But these 4 fields need to be conditionned respectively by an another linked view. (meetin1, meeting 2, meeting 3, meeting 4) If this one is empty → then the field will appear, if it’s not empty, the user already have a meeting with someone…so it doesn’t have to appear…

More infos :

I have a table « meeting résume » in wich i have records (one record / one collaborator).

For each record there are fields named « meeting 1, meeting 2, …3 … & 4 »

My form is based on « available people » table. → i use look up from meeting resume

Heres how i want to make it :

I choose my name → from linked view of meeting resume → it report the 4 fields « meeting 1, meeting 2, …3 … & 4 » → read only

If this field (meeting 1 read only) is empty, then my collaborator will see m(x)availablecollab(x) field in the form and can choose one to meet in the list.

If the meeting1 it’s not empty → he already have someone to meet on this slot so it doesn’t have to appears.

But when i use « show field only when the « meeting1 » (read only) is empty on my « m2availablecollab2 » → the opened form result on a blank page. When i turn off the condition, my form appears….

I hope i’m clear…. Not easy to explain.

Thx for your help i twill be very precious if it’s gonna work…

Hmm, not easy by just reading it, but couldn’t you work with a seperate view that has all your filters and conditions and limit your 4 questions (meetin 1, …) to a selection from that view?

image