! Google login is no longer working on desktop app!

7106 25
Showing results for 
Search instead for 
Did you mean: 
6 - Interface Innovator
6 - Interface Innovator

Using the google sign-on in the desktop app now shows an error from Google: “This browser or app is not secure” and then does not allow logging in

Please resolve

25 Replies 25
4 - Data Explorer
4 - Data Explorer

Darin, I got it to log on asking to reset my password. I put my email (gmail), asked to reset my password, I reset and log on. Super simple, I got it just doing this. Try again and say me :grinning_face_with_big_eyes:

4 - Data Explorer
4 - Data Explorer

Yeah, I’m not resetting my password for this. It’s clearly a glitch of some sort and if I had to reset it every time I wanted to log on I’d probably just give up.

4 - Data Explorer
4 - Data Explorer

Checked all security preferences and found nothing that could interfere on my end. Following…

4 - Data Explorer
4 - Data Explorer


I had the same issue, check if your Airtable’s password is saved into your Google Chrome settings, then just put your e-mail (Gmail) and password into the common login form.

It worked for me !

Have a good day dudes

Hi Robin - I’m afraid that won’t work - the issue here is not signing into an AirTable account, it’s for users that use a Third Party login (i.e. you sign in with your Google account) - thanks for the attempt though!

I’m surprised that this is still an issue after two weeks - it seems like a pretty big problem, not being able to log in.

I’ve tried just creating an AirTable password, but it doesn’t let you when you’ve already got an account through a third party…

Can the Admins please respond with an update on this?

4 - Data Explorer
4 - Data Explorer

Hello, exactly the same issue. I discussed a bit with support and show them the issue (like 2 weeks ago) but nothing…

The desktop app is a must-have and it’s becoming embarrassing!

4 - Data Explorer
4 - Data Explorer

Also having this issue with the Mac desktop app, but not the iOS mobile app.

Error message same as described above (thanks, Darin); full error message is as follows: “Couldn’t sign you in This browser or app may not be secure. Try using a different browser. If you’re already using a supported browser, you can refresh your screen and try again to sign in.” My google account is set to allow sign-in to Airtable.

4 - Data Explorer
4 - Data Explorer

Unfortunately, still same here…

Popped in to say same issue for me - Google login does not work on desktop app. I was able to log in (to post this comment) fine in Chrome using Google login.

4 - Data Explorer
4 - Data Explorer

My solution for this:

  1. Login to your Airtable account via website (e.g. Google Chrome)
  2. Click your profile picture → Account

You should see a button to add an Airtable Password to your account (to the right of your profile picture)

  1. Add another password to your Airtable.
  2. Open up the desktop app and login with the email from your Gmail and the Password you have just created.

It should be done from there! Good luck!