Re: Having trouble deleting and re-coding script

1128 2
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer

Hi everyone! Newbie to anything this technologically advanced and have no idea what I am doing LOL. I am using the Airtable “Create Scripts for Multiple Templates” script, but I don’t need the “Type” table.

Is there anyone here who can educate me on how to edit the script so it doesn’t include any reference to the “Type” table and still runs through what I need it to?

Thank you in advance!

7 Replies 7

Hi Katherine, I think I’ve accomplished what you’re looking for here. You should be able to view the script.

As requested, I removed all references to the type table. I also renamed a bunch of the variables because the originals were too confusing for me.

Let me know if you have any questions; I was planning on explaining what I did but doing this gave me a bit of a headache heh and I figured I’d just pass you the solution first

Lol. Sometimes it takes longer to explain something than to do it!

Ha yes, this is especially true for this one I think. The headache this one gave me still hasn’t gone away!

Hi Adam, thank you so much, it worked in the test I ran but now I want to make this script part of an automation and its not working! its telling me there is an error in line 6 because input.config.table is not a function. what does this mean?

Hi Katherine, ah you’re attempting to put a script for the Scripting App into an automation. That isn’t going to work I’m afraid, and large portions of it will need to be rewritten.

We’re going to have to set all the tables and fields manually instead of being able to click and select them via the scripting app, and also pass in the ID of the record that triggered the automation via input.config()

Let me know if you need any help with that

Noooooo!!! darn it yes I will need some help with that. Well actually a lot of help…

Can I engage you to assist? How do we do that?

Yeap sure! I’ll private message you