Re: How can I convert text from formula to linked items

3400 1
Showing results for 
Search instead for 
Did you mean: 
5 - Automation Enthusiast
5 - Automation Enthusiast

I have a Zapier firing when a certain label is added in Evernote. I am able to get the record added correctly into Airtable. Inside the text of my Evernote, I have encoded who the note is about. Example below:

<NAME: First Person, Second Person, Third Person>

I have a formula that can find “<NAME:” and I can pull the correct list of names, comma separated string. However, I also have a contacts table with peoples first name.

How can I get a column that has to be a formula (in order to pull the text) and get it linked to a Contact.

The ultimate goal is to be able to have a view of my contacts and see what Evernotes were tagged to their name.


11 Replies 11

By copy-and-pasting the resulting formula value into a linked-record field, you can either link to an existing record of the same name or, if no such record exists, create a linked record with that name. IIRC, the copy-and-paste can be performed by Zapier; that is, by saving a text value into a linked-record field with Zapier, you can link to/create a linked record.¹

  1. Off the top of my head, I’m not sure where I tested this out, but I’m pretty sure it’s not in any of my demo bases. Instead, I think I incorporated it as part of a base I created for a client that was designed to sync a Google Sheets-driven advertising buy calendar with Airtable. When an entry was added to the Sheet, a corresponding record was added to the base. At least, that’s how I remember it; if I get a chance, I’ll go back through my notes and confirm.

I was hoping there would be a better way than a hack. I know I can manually go in and copy the text from the formula column into a linked column and it will do what I want. I am hoping to find a way without this manual step.

You mentioned that Airtable can do this “copy/paste” step. How is that possible? Not seeing it.

That puts you at the head of the class, as this convenient function is one of Airtable’s best little-known secrets. :winking_face: I’ve used it to create as many as 468 new linked records at a time, which to me takes it out of the realm of ‘clever hack’ and into that of ‘essential functionality.’

Not Airtable, but Zapier. (And presumably Integromat, et al. — that is, using a third-party integration service.)

To do it fully automatically, you’ll have to put up with non-realtime performance. All integration tools (to the best of my knowledge) work off a polled trigger: An updated record does not directly trigger the service. Instead, the service checks Airtable for new records or new records in a view on anywhere from a 1- to a 15-minute cycle, depending on the service and the level of account. (There is a way to hack together a somewhat more realtime-ish response using a Slack channel to trigger the integrator; search Community posts for ‘Slack’ for more info. In my experience, response time can vary greatly, from seconds to 5+ minutes, depending on [presumably] current Airtable and Slack load levels.)

If you don’t mind a little manual effort, you can create a custom URL as part of the record that sends to a Zapier (et al.) webhook. This provides near-instantaneous response, but it does require one to select the URL. I’m currently playing around with the Chrome Zapier plugin to see if it might provide a similar function a little more seamlessly.

If you need a fully automated, ‘pure’ Airtable solution, you’re currently out of luck. I’m hoping that as Airtable becomes a more robust platform for application development, it will backfill functionality it now lacks. In that case, such a workaround might be only a short-term annoyance.

Don’t need real time updating.

How can Zapier do a copy/paste function that would trigger the linked column? I don’t think I’ve seen that feature in Zapier.

Simply store the text value into the linked record field. Not precisely copy-and-paste, but same idea and result.

Hmm, that will be a little more challenging. It is easy for me to search for a specific string pattern once I’m in Airtable. But I don’t think I can get to this level of sophistication in Zapier before it gets to Airtable. Any ideas for doing this in Evernote?

Actually, I figured it out. Hopefully this will help someone some day :slightly_smiling_face:

In Evernote, you can create “Named Variables” ( For my use, I called my variable “Attendees”. Then, I used a comma separated list with the names. Ex: Attendees(Joe Smith, Jane Doe, Adam Blake).

I use the trigger of adding a new label to my note. So any notes I wanted copied to Airtable, I just add that label.

In the zap action, it sees my named variable and I can map it to a column that is linked to my “Contacts” table. Airtable automatically takes my comma separated values and splits them into full names and try to link them correctly.

I “think” this will work for me. I’ll do some more testing. Initial tests look good.

Hey @W_Vann_Hall,
thanks for all your replies all over Airtable forum. It has helped me a lot !

I’m actually using a zap to do this c/paste task between a formula result and a linked record. I thought like you, that it would have the same results, but it doesn’t. And I can’t figure out why.

It does do the c/pasting, but instead of linking the formula result to an existing record that has the same name, it creates a new record (with the same name/string value, in the linked tab) and link to this new record. Since this new record is not defined, the automation misses the point.

You see what I mean ? Usually, when you c/paste a string into a linked record, Airtable links it to an existing record with the same name (if it exists). With zapier, it doesn’t do it.

Do you have a solution maybe ?
thanks in advance !

I’ll have to check to see if that’s a new behavior. The Zapier-driven version of my Scheduling Framework uses just that same copy/paste Zap to create bidirectional links between parent and child tasks, and the last I ran it, it worked fine. (Admittedly, that was several months ago…) It should work. You may want to check for leading/trailing spaces — oh, and make sure to try it with a linked-record value that does not contain an embedded whitespace character: There are some circumstances where integrations (or even just OS-based copy/paste) insist upon wrapping copied values in implicit quotation marks. I’ve not seen it in Zapier, but I can’t say I’ve ever tested it as such…