Re: How to pre-fill a form with a record from a synched table?

2002 0
Showing results for 
Search instead for 
Did you mean: 
6 - Interface Innovator
6 - Interface Innovator

Hello all,

I hoped to close a project that I worked on for a few weeks today just to realize that synched tables do not behave as I expected. Using synched tables, records get a new Record ID in the destination.

My workflow works a lot based on (pre-filled) forms. Now how can I pre-fill a form with a record from a synched table?


13 Replies 13

Just use the formula RECORD_ID() in your source table, and then sync that field to your destination table.

That does not seem to work because records get a new Record ID in the destination.

You can see the record ID from the source table in your destination table. But no, that doesn’t represent the record ID of that record in the destination table. It lets you pinpoint that record in the source table, though.

In my case, the Record ID is dynamic. The record contains a button, prefilling another form referencing to the record that was selected in the first place.

The Button looks like this:”&{Record ID}

The dynamic {Record ID} references to the source but should refer to the destination. I am sure there are good reasons why record ids change in synched tables… for this case it sucks.

The form I want to fill “lives” in the destination table, not the source table. If that makes sense.

Not sure I understand what you’re trying to do. You have access to both record ID’s in your destination sync table, so you can do whatever you want to do based on either record ID that you desire.

Also, destination sync tables are read-only, so you can’t change any records there (unless you add new fields on the destination side).

If you’re having trouble with creating your prefill link, I would check out @kuovonne’s Prefilled Forms extension:

Thanks for taking the time to help. Let me try to explain better.

EDIT: While I was writing everything down, I noticed my mistake. The form must live in the destination base. Now it works. Thank you for your help!

Just to clarify, your form can likely live in either base, but I’m glad that you got it working for your needs! :grinning_face_with_big_eyes:

I don’t think the form with the button containing the formula below can live in either base:{Record ID}

Only within one base the “dynamic” {Record ID} is known and refers to a record in that base.
If you are interested I am happy to explain it in more detail.

Like I said, you have access to both record ID’s, so you could change that link to use either ID that you want. I’m glad that you resolved your problem! :grinning_face_with_big_eyes:

There are two bases:

  1. Base: Briefings
    a) Table: Briefings*
    b) Synched Table: Designs**

  2. Base: Designs
    a) Table Designs**
    b) Synched Table: Briefings*

New Designs need to be submitted to 2 a) using a form since the submitters do not have access to any base.

In base 1, the Record ID of records in 2 b) is not known. This is only known in base 2.
I still think it matters where the form lives. Or am I missing something?

No, you are incorrect. You can see both record ID’s in both tables.

But don’t worry about it if you’ve already solved it. You already said that you figured out a solution, so I would go with that.

Like I told you in my very first post (and several times after that), you can sync the record ID formula field from one table to the other table, so you can then see the original record ID alongside the new record ID.

Once again, you can see both record ID’s for the same record in the destination table — the new record ID and the original record ID. You are not understanding this concept of seeing both record ID’s.

You just need to reference whichever field you want based on the name of your formula field that displays whichever record ID you want.

So if you send users to a form based on the other table, then you can dynamically use the record ID from that other table, because you already know what it is.

Of course, I can sync it but it does not help since it is not the Record ID in the destination. I hope I am wrong because I can learn something in that case. If you are up for it, I can show you in a screen share what I mean.