Re: Keyboard shortcut for checkbox?

Jump to Solution
1937 0
Showing results for 
Search instead for 
Did you mean: 
6 - Interface Innovator
6 - Interface Innovator

Not sure this is the right category, but…

Is there a keyboard shortcut to check a checkbox? it’s incredibly annoying when doing data entry to have to switch to my mouse to check off a box… i’ve checked the shortcuts menu and don’t see it, searched the forum here and don’t see it, but i might not be searching on the right combination of words?

any clues on this would be great… i’ve tried spacebar and enter and shift enter and a variety of other possible, intuitive solutions but none of them seem to do the trick.

if it’s NOT a thing… then @airtable dev… could it please BE a thing! :grinning_face_with_big_eyes:

1 Solution

Accepted Solutions
18 - Pluto
18 - Pluto

You can type the number “1” and RETURN to check the box, or “0” and RETURN to uncheck the box.

See Solution in Thread

8 Replies 8
18 - Pluto
18 - Pluto

You can type the number “1” and RETURN to check the box, or “0” and RETURN to uncheck the box.

OMG you are a life saver.
thank you

Ha, you’re welcome! Glad I could help! :slightly_smiling_face: If you don’t mind, could you please mark my comment above as the solution to your question? This will help other people who have a similar question in the future. :slightly_smiling_face:

You could also just hit RETURN when the checkbox field is active. That toggles the checkbox state.

you’d think… but i tried that and space bar and neither did the trick…
but the 1/0 does it as ScottWorld suggested.
maybe it’s something wrong at my end, who knows… but now I have a solution, so i can keep working without ripping my fingernails out.

Right, as @Justin_Barrett mentioned above, nearly all variations of RETURN should normally work to check & uncheck the checkbox field:

Return, Option-Return, Command-Return, Control-Return, FN-Return.

All of these work for me when checking the checkbox field.

However, if for some reason RETURN is failing, then you can revert to the trick that I outlined above.

Odd. Maybe it’s a browser/OS thing, or something specific about the process. To elaborate about how I get this to work, I’m using either the Tab or cursor keys to navigate between fields, and Enter to toggle the checkbox state once I reach a checkbox field. This works for me in both the standalone desktop app (which I use 99% of the time) and the browser (Chrome) on macOS Catalina.

i’ll check more into it… that’s precisely how I EXPECTED it to work…that would be normal and intuitive… so yes, it’s likely my browser.
Thanks for verifying that it SHOULD work that way. I’ll see if i can sort it out at my end. I do have one extension that i use for tracking my billable time… it seems to interfere with a lot of things. That’s probably the culprit.

But since I can get around it with ScottWorld’s fix, that’ll help.