Help

Linked fields not populating

Topic Labels: Base design
277 3
cancel
Showing results for 
Search instead for 
Did you mean: 
shannonwinters
4 - Data Explorer
4 - Data Explorer

Hello,

I have two tables that I am trying to link together.

One table is an instructor table called Instructors AY25 and the first column contains the instructor name and the other columns contain instructor information, including the catalog number for the course they are teaching.

Another table is a course table called Courses AY25. The first column is a catalog number and the other columns contain course information.

In the Instructor table, I have tried changing the catalog number to a linked field and linking it to the Course Table. This works and allows me to look up fields from the Course Table, but the new column that is created on the Course Table that should link back to the Instructor table is empty.

Here's the instructor table catalog number:

Screenshot 2024-03-22 at 11.21.36 AM.png

I have linked this to the course table:

Screenshot 2024-03-22 at 11.22.19 AM.png

But the column it creates on the Courses table looks like this and is empty:

 

Screenshot 2024-03-22 at 11.22.09 AM.png

I want the instructor names to pull into this column.

 

 

3 Replies 3
sambehrens
4 - Data Explorer
4 - Data Explorer

The Catalog Number on the Instructor Table will definitely need to be a linked record to the Course Table.

One thing you will need to remember is the first column will be what shows up and is searchable for the linked records. I was not sure if I was understanding properly, but the Catalog Number must be the first column of the other table in order for the Catalog Number to even be selectable. (Again, this may already be done)

In this example I made both lists first in the first column of each table and then selected the Catalog # for each teacher.

Hope this helps a little!

sambehrens_0-1711139978780.png

sambehrens_1-1711140149696.png

 

 

Could you provide a screenshot of a single record from the Instructors AY25 table where the linked field to Courses AY25 is populated, and a screenshot of that record in the Courses AY25 table with the linked field to Instructors AY25 visible?  Better yet, if you could provide an example base with no data in it that'd allow us to troubleshoot for you much more easily

I've not encountered a situation where a record with a link to another table didn't populate in said other table and am curious why this could be happening

shannonwinters
4 - Data Explorer
4 - Data Explorer

Thank you both for your help! I found the error on my end and it was completely a user error. My catalog numbers in the Course table actually had a space at the end of each and so when I was trying to link from the Instructor table it was creating new rows at the bottom of the course table. Thanks again!