Single Select Field Text Not Displaying/Visible

Topic Labels: Views
1459 6
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer

I pasted several records into a grid, as I have done in the past (nothing has changed that I know of). Now, the grid view no longer shows the text of the Select (dropdown) item for the inserted records (existing records are showing the text).


Odd thing is the values are indeed there (and I can see them listed when going into the Customize Field Type option for the Select). The text in the non-Select fields is showing, so it just seems to be something glitchy with the visual for the grid view on Select fields. Again, the text is there (and I can see it if I create formula fields based off those fields). When I try to remove the colors, I just get grey boxes.

Any idea why this just started happening?

I have tried scrubbing the original data and making sure there is no trailing spaces, etc. and re-pasting it. This is really odd since I have been doing this a lot for several years and have never seen this before. So, any advice on what could be causing it would be greatly appreciated.

Thank you!

  • Michael
6 Replies 6
7 - App Architect
7 - App Architect

Hello Marin,
I just copy/pasted one record including a single select field and the new record shows the text.
Did you try wiping out cookies and all? Airtable uses local browser features, sometimes one could get in a wrong state somehow?

Thank you, Grunty. I tried those and even on different browsers. I’ve even tried copy-pasting a single value and it is still happening.

It’s as if a gremlin has gotten into the system. Any other ideas from you or anyone else would be greatly appreciated.

If the text is there but yet not visible, one improbable possibility is the text being somehow assigned the same color as the background, so you see all in uniformity. I don’t know how the text color could be set, don’t see an option for that.

Maybe you tried it already, but in this supposition, you could change the color of an option - turn a light-colored one into dark-colored - just to see if the text retains its current color, differentiating from the background.

Last recourse : make the field simple-text and then turn it back to single-select. Chances are it will return to show as expected onwards.

Hi Grunty,

That last recourse item and changing it to simple-text and then turn it back to single-select seems to have worked. Great idea!

Thank you!

7 - App Architect
7 - App Architect

Great to hear! As in the movie, gremlins only understand the hard way…
Please mark my last post as Solution :winking_face:
so others with a similar issue will know this thread contains a help for them.

Thanks @Grunty! Your ‘last recourse’ did the trick for me as well.