Help

Re: Sorting Alphabetically

Solved
Jump to Solution
1842 4
cancel
Showing results for 
Search instead for 
Did you mean: 
Data_Team
5 - Automation Enthusiast
5 - Automation Enthusiast

Hi all - I have a table in grid view that I’m trying to group and then sort alphabetically.

The table is:

  1. Grouped by StateOrProvince from First-Last
  2. Sorted by StateOrProvince from first-last

No matter how I group, sort, etc. I can not get the table to group/sort alphabetically by State.

Any insight you can offer is so appreciated. Thanks!

Airtable

1 Solution

Accepted Solutions

Single-select fields are sorted in the order in which they appear in the single-select list. Go in to customize your field, and you can click on the “Alphabetize” button. (Or you can manually drag-and-drop the options into the correct order.)

See Solution in Thread

8 Replies 8

Your screenshot is sorted alphabetically.

@ScottWorld ah the screenshot does not accurately capture. All 50 states are in this table and yet not sorted alphabetically. If you could see the whole table you’d see that after AL and AK should be before AZ, etc.

Single-select fields are sorted in the order in which they appear in the single-select list. Go in to customize your field, and you can click on the “Alphabetize” button. (Or you can manually drag-and-drop the options into the correct order.)

@ScottWorld, I see it, thank you!!

Hello, I have a similar problem, but don't see or have that option. How do I access it.  Not seeing: customize 

Kaiserin
4 - Data Explorer
4 - Data Explorer

Hi I also have the same problem! I have a list  which does not sort alphabetically even when I click on sort A-Z, it seems to stay in the order that I entered it.

Nor can I find the customise button

 

this is ridiculous for a product that should simplify the management of the information.

 

The Help service does not seem to engage with my issue when I contact them and just cut and paste lots of videos

 

I am having the same issue. It is making it difficult to do my work because the sort feature only seems to sort correctly with one field. When I add a second field to sort, it doesn't sort as it should. In my case, I need the fields to sort by Year and then by Title - but the titles are not sorting alphabetically within each year. I just reached out to the Help service but now I wonder if I will ever get a reply.

Found out that if there are blank characters in the data, it will take those blank characters into account when sorting the records. To remove the blank characters from 6k+ records, I created a new Formula field that pointed to the field I needed to trim (in my case it was a single line text field for "Year"). In the new Formula field I set up the formula TRIM(Year) and it removes the blank characters from current entries and new entries.

The students who do our data entry still use the single line text field to enter the year. That field is far too integrated into the workflow for me to get rid of it. But now I can count on the Formula field to create an entry that automatically removes any blank characters from the year. I only use the Formula field for the year when I am creating a group or trying to sort the data.