transfer personal credits to workspace

Topic Labels: Admin Collaboration
736 2
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer

Hi, I have an issue with transferring personal credits to my workspace. I just updated my plan to a business one, and now I want to transfer all my personal credits, but it doesn't work. I already resublmitted my card details, still no success. Please sort this out for me ASAP! 

2 Replies 2
Community Manager
Community Manager

Hey there @tamaskoncsik,

Someone from our support team will get in touch with you shortly.

Have a great weekend!

6 - Interface Innovator
6 - Interface Innovator

@tamaskoncsik & @MaddieJ 

I keep running into this problem as well and it's a costly problem.... Has it been fixed for you @tamaskoncsik ?

First time I ran into this issue I had pre-loaded a workspace with credits before upgrading to the business plan.
After upgrading the plan to business, the credits on the workspace had just disappeared - which in a way is expected as they should be used by the upgrade -  but also my creditcard got charged. After some back-and-forth with support it got sorted out.

But the fundamental issue persists when trying to pre-load my Business workspace before the next billing cycle hits. Again I have gone through the normal steps of allocating credit to the business workspace.
I even hit a 'confirmation' button!  But the problem is, Airtable does not actually apply this credit to the workspace.
The workspace keeps showing 'Your workspace does not have any credit'.  

Since there is no way to apply credit through the new Business Admin panel, credits are effectively broken for business plans as of right now!