Help

Zapier integration not complete?

2542 4
cancel
Showing results for 
Search instead for 
Did you mean: 
Jens_Jakobsen
4 - Data Explorer
4 - Data Explorer

Hi

I’ve created an integration from Zapier to AirTable.

My blue sky scenario would be, that when ever I populate a AirTable base with a new record, this record will include a unique email address for each row.

I want Zapier to detect each new record and send and email to the email value I put in the AirTable row. However, from my AirTable rows I frequently use “Link to another record” to other tables, and this is where I pull the email value from.

Zapier cannot read values in AirTables where the value is based upon values from “Link to another record”, is this just me?

Please see my screenshot.

Image 18-11-2018 at 14.50.jpg

Any help is welcome - I don’t know if this is a Zapier problem or an AirTable problem.

4 Replies 4
Minji_Ro
6 - Interface Innovator
6 - Interface Innovator

i think i’ve run into the same issue you’re describing here.

what worked for me was adding additional columns that mirrored the linked columns to the table, so for your example, i would add another column “Begivenhed as text”, make it a formula where it just equals {Begivenhed}.

Zapier should recognize this new “as text” column with the correct contents. hope this helps.

Thanks Mini_Ro I thought of doing exactly the same :slightly_smiling_face:

However I’d wish that was possible, instead of the case where Zapier simply cannot see the field.

Hi

There are two ways you could deal with this requirement:

  1. Create lookup fields within the table you are triggering the Zap from which bring the data from the linked record into the triggering record, or

  2. Use a Find step in Zapier to lookup the records in your linked tables (using the record IDs held in the link fields in the triggering table).

Hope this helps…

hi all

I’m struggling to get any of the workarounds to work for me - this is for an Airtable/Zapier/ActiveCampaign integration.

I am wanting a trigger where:
a) new record appears in a view
b) a contact with an email address contained in that same view is emailed

The challenge is that the email address of the column is being “lookuped” from another table, and ActiveCampaign isn’t therefore reading the email address for me to complete the search and identification of the contact.

ActiveCampaign is coming back as registering “no data” in the field at all, which is obviously a problem.

Keen if anyone has any suggestions for a workaround here - I’ve tried the approach of creating another column and putting that as equal to the lookup column…but this data is still not being registered by ActiveCampaign, which continues to think that the field is empty.

Many thanks in advance!