Airtable Saving Cleared Column Data

Hi everyone,

I’m not sure if I’m missing something or what but when I clear out all the data in a column and then paste new data into the column, it still has the previous data saved?

I know this because when I switch from single line text to multiple select, the old data shows up as a bunch of choices. Any help?

The solution I found is to delete the column and make a new one but I have a ton of data and this seems like it may lead to issues half way through my project.

Thanks.
45%20AM06%20AM

Are you sure you didn’t convert to multi-select before clearing the column? Because when I clear a single-line text field and then convert to multi-select, it doesn’t retain the old values as possible options.

I’m using the latest 64-bit Chrome under Windows 10. If you’re still having this problem, email support@airtable.com (and post here, if you would) with the OS and browser versions involved.

You are right. I was testing it back and forth so I’m sure I selected multi-select while the data was in the column. Do you know why the column would save all the data when selecting multi-select but not erase it once I cleared the entire column?

Thanks.

Well, it doesn’t save the data, per se: it saves the options. When you convert a single-line text field to multi-select, it automagically creates a multi-select option for every unique value in the column; this is an incredibly handy tool for populating multi-select options without having to retype every potential value. At the point, then, you have a multi-select field with a defined option for every unique data value.

As is the case with any multi-select field, you don’t want clearing the field data also to delete the configured options, so you end up with a blank column but with every select option still defined, ready for data input. Ordinarily this isn’t a problem — but if you’re defining a base, you can end up with unexpected results if you are in the process of reconfiguring fields with existing data. (Want to drive yourself completely nuts? Try redefining the configuration of an already-populated datetime field, toggling and re-toggling the ‘Include time field’ and ‘Use GMT’ options. :wink: )