Cannot copy dates from Excel


#1

Hi there,

I’ve recently discovered Airtable and am in the process of migrating my Excel spreadsheet to an Airtable base, but cannot seem to copy dates from Excel to Airtable.

When I try copying dates, only some of them are copied over to Airtable, but in the wrong format (even though I have both Excel and Airtable columns set up as dd/mm/yyyy).

Any idea how I can resolve this? I don’t really want to copy all those dates manually, as there are around 1000 in total.

Thanks!


#2

Firstly, you should be able to change the format at whim, while customizing the field. Secondly, customize the field to be a date field, before pasting any data.

Let me know if that helps.


#3

Hi Andrew,

The field is already customized as a date field, but it still doesn’t work. I find it weird that random cells are filled in (though they are in the wrong format), but most of the cells are blank.


#4

Can you show us an example of dates? Try just pasting in about 10 rows of whatever you were trying to paste in your table. Then highlight it. Then in this forum comment text editor click on the “</>” (Preformatted text).


#5

Here you go:

image


#6

I figured out how to do it, all I had to do was change the formatting in Excel to long date format (so I had dates like “January 23rd, 2017” instead of “23-01-2017”), and then I could copy them over to Airtable perfectly.

Thanks anyway for your help!


#7

You’re welcome! I’m glad you figured it out :slight_smile:


#8

First I thought this was the exact same problem I’m having right now. Some dates are left blank while copy/pasting from Excell. Date formats are ok, but Airtable changes the day and month. And since there are no months beyond 12, the record than stays blank. I tried several things, like changing the date format as suggested to long format, but that makes things even worse - no dates are copied ;-( Any suggestions?

50


#9

The weird thing is I’m having also a problem with copying decimal numbers - the number 0,89 becomes 89 in Airtable. Both columns, in Excel and Airtable, are set up as numbers. Any idea? Related to the previous issue?

33