Character limit in shown answers of multiple select option

Dear all,

I have a problem with my formular. I wrote some multiple select answers when creating the formular but when opened to be answered, some texts are cut, so only first part can be read. How can I address this problem?

Thank you

Lidia

Wow, looks like you just stumbled upon a major bug/limitation of Airtable. I would report this bug to support@airtable.com.

You could leave your question on the form as-is, and just add some descriptive text above that question on your form to explain what #1 says… but that would look extremely strange and ugly and bizarre.

A better option using descriptive text would be to just change your multi-select field to numbers, and add descriptive text above it to be an “index” as to what the numbers represent. The good news is that descriptive text doesn’t seem to have a limit on the Airtable forms. The bad news is that these options will just show up as numbers in your base, but you could create a formula field in your base to translate what the numbers represent as text.

Without being forced to switch to another form building software platform altogether, your only other options would be to change the structure of your base.

Instead of using a multi-select field, you could switch it to a linked record field instead… where the choices would be stored in a linked table. Airtable forms will still cut off the names of linked records, but I think you’ll get a few more characters out of it. You’ll have to experiment to see if you can squeeze a few more characters out of it that way.

You could also separate out your multi-select field into 5 different checkbox fields… so you would have 5 different checkbox fields. Then, on your form, you could put 5 different checkbox fields on the form, and add extra descriptive text to each one of those 5 fields. Not the best solution nor the prettiest solution nor even the best way to setup a table, but it would work.

Otherwise, you’d have to turn to external form building tools to make this work properly. :frowning:

Hope this helps! If this answers your question, could you please mark this comment as the solution to your question? This will help other people who have a similar question. If not, please let me know what else you need help with! :slight_smile:

1 Like

Hi Scott,

Thank you very much, I’ll check what you are suggesting! :smiley:

Lidia

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.