DATEADD not working?

Hi All,
I am trying to use the DATEADD formula to add a number of years to a date, The date is in one table and the number of years to add is in another table.
DATEADD(Date,{Years till expiry}, ‘Years’)
This just returns the same date as the date field. Annoyingly if I remove the {Years to Expiry} and just put a number in there it works fine, But i need to pull a different number of years depending on another field.

I am trying to produce an expiry date for a qualification which is linked to a Google drive. the qualifications are listed in another table with the years to expiry number linked to each qualification. once this works i will want to run some conditional formatting in a report to see which qualifications are out of date.
I have tried formatting the columns to integer and decimal.
Thanks in advance

Steve

Welcome to the Airtable community!

Change your lookup field to a rollup field. You can use the formula SUM(values). Since there is only one value, the sum will be the same as the actual value.

Lookup fields do not play well with formula fields. Sometimes they return arrays and sometimes not.

1 Like

Thats great thanks time to look at rollup fields!!

Steve

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.