Formula Format from Currency

I have an issue with the formula in the ID field not displaying correctly as it has several decimal places even though the column it’s getting the data from is set to currency integer (2). How do I get it to display correctly?

This is how it’s showing:

This is my formula for calculating the Amount Outstanding:

And the format:

And this is my formula for the ID field:

Anyone know a way to fix this?

I haven’t been able to recreate your error yet. I had a very similar setup to what you described, but I wasn’t using a roll-up field. In any case, it seems your formula is losing the precision settings outlined in previous fields.

You might have some luck rounding Amount Outstanding in the ID field’s formula. See the round functions in the numeric section. They all let you specify precision.

@NHAD_Team

You just need to wrap the reference to {Amount Outstanding} in the ID field formula in a ROUND() statement.

...
"- £", ROUND({Amount Outstanding}, 2), "- "
...

@Zollie @Jeremy_Oglesby You guys are awesome. Thank you!

1 Like

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.