Sorting Single line text not working

I am sorting alphabetically the Primary Field which is a Single line text. It does not work. I have some data for this Primary Field that are duplicates and when I sort it, it should be right next to each other but it’s not.

How can I fix this?

Welcome to the community, @milktea!

This issue could be caused by extra spaces within the text of the field.

Unfortunately, Airtable truncates all extra spaces in a field so you can’t visually see them, even though the extra spaces are there.

This is a huge bug in Airtable which they have never fixed.

Check to see if this is the problem affecting you as well: Double-click into one of your text fields that isn’t sorting properly, and see if the extra spaces suddenly appear.

Thanks! I tried playing around with adding a space in the beginning and removing it and that fixed it.

I’ll be careful with copying and pasting data in since this is how it first started.

1 Like

@milktea Great! If you don’t mind, can you please send a quick email to support@airtable.com to tell them about this issue that you had, and to request that they please display ALL SPACES onscreen at all times? If people can’t visually see their extra spaces onscreen, then they can’t figure out problems like this when they arise.

Yes I sent an email!

Great! :smiley: :raised_hands:

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.