Using DATEADD doesn't aggregate the data

Hi airtablers

I’m trying to create a business schedule table.
There are ‘start time’ and ‘duration’(a lookup value from a different base) fields, and I try to formulate the ‘end time’ field by aggregating the first 2.

For some reason the below formula gives the start time unchanged.

DATEADD({Start time},Duration,'seconds')

I tried to change the seconds to minutes and hours with same result. {Duration} also didn’t change.

The formatting option “Use the same time zone (GMT) for all collaborators”, is disabled in both date fields.

What am I doing wrong?

Thanks

FB_IMG_1582410496109 FB_IMG_1582410492624

I was able to see the same problem as you. I suspect the problem has to do with the lookup.

My workaround was to force the {duration} into a number by adding zero to it.

DATEADD({Start time}, {Duration} + 0, 'second')

In my test, only {Duration} is a lookup; {Start time} is a regular date/time field.

1 Like

Thank you so much :slight_smile:

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.