Help

Changing the Decimal space in a currency field

Topic Labels: Base design
1129 2
cancel
Showing results for 
Search instead for 
Did you mean: 
Tiaan_Terblanch
6 - Interface Innovator
6 - Interface Innovator

Hi, we are importing data with a CSV and have a few fields with currency.

On the CSV, the amount reflects in the following example:

397,00 €, but when we import it, Airtable changes it to; €39,700

0,97 €, but when we import it, Airtable changes it to; €97.00

Our field is set on Currency and €1.00.
Please see the screenshot attached.

Please, can you help rectify the fields so that the amounts are the same as in the CSV file?
Thanks

2 Replies 2
JLindem
6 - Interface Innovator
6 - Interface Innovator

I don't think Airtable has the formatting settings for the field that you need to do this. I think the issue comes from Airtable interpreting the comma as a thousand separator, and not a decimal. It may be smart to email Airtable support about this to request it as a feature — there are probably others that also want to change the decimal symbol from a point to a comma. 

As a workaround, perhaps you can change the csv file using find and replace to either remove the thousand separator or change the decimal symbol from comma to point? 

Tiaan_Terblanch
6 - Interface Innovator
6 - Interface Innovator

Thank you.
I need to make sure that most of my input is automated, so in the end, I added a few columns (that I can later hide) to make it a bit easier. I added a formula column dividing my amount by 100, giving me the correct amount I needed.
It is long-winded, and I had to add about five extra columns, but that works for me now.

Airtable should look at this issue as many people want to use it as a budget tool or expense tracker, and the 1000 decimal separator makes it difficult.