Help

Upcoming database upgrades. Airtable functionality will be reduced for ~15 minutes at 06:00 UTC on Feb. 4 / 10:00 pm PT on Feb. 3. Learn more here

Hide App window when script executed

Topic Labels: Scripting extentions
885 6
cancel
Showing results for 
Search instead for 
Did you mean: 

Is there a feature or method to DISABLE the apps window from displaying/sliding open when a script is executed via a button in a table? Or, is this a feature request? I’d just like it to run in the background when manually executed, like an automation.

6 Replies 6

No, the Script App will always open when executed, but is there a reason you can’t just convert your script to Automation Script Action?

That’s what I wound up doing, yes! But now I ran out of automations!

What does it mean to “convert script to Automation Script Action”?

I have the same need to hide the app from running on the side. I have a Button that is set with Action = Run Script. In my Button script all I am doing is setting a value in a field on the record.

Thanks!

The Script App and the Run Script action for Automations are very similar, but have certain functions that only work in one and not the other.

Making sure your script is compatible with Automations is not a one size fits all process. Generally, you have to adjust all your input.somethings in some way since all Script App inputs don’t work in Automations (and vice versa, the inputs for Automations don’t work in Script App). For you, you likely have your button used with input.recordAsync() to identify what record to update values for. Obviously that’s not going to work in an Automation, you’ll need to pass the appropriate record ID from the Automation’s trigger.

Also, none of the output.somethings work in Automations (no one is there to read the output.)

The Scripting API documentation marks what functions work where.

You’re right that in my Button script I’m using input.recordAsync(), doing this:

let record = await input.recordAsync(‘Choose a record’, table);

Is there something about this that causes the script to run visibly in the side panel? That’s what I’d like to prevent somehow, I’d like it to run “silently” and just do it’s job.

To quote myself above,