Help

Formula Format from Currency

Topic Labels: Formulas
Solved
Jump to Solution
2964 3
cancel
Showing results for 
Search instead for 
Did you mean: 
NHAD_Team
5 - Automation Enthusiast
5 - Automation Enthusiast

I have an issue with the formula in the ID field not displaying correctly as it has several decimal places even though the column it’s getting the data from is set to currency integer (2). How do I get it to display correctly?

This is how it’s showing:

Screenshot 2020-02-06 at 11.07.25

This is my formula for calculating the Amount Outstanding:

Screenshot 2020-02-06 at 11.07.52

And the format:

Screenshot 2020-02-06 at 11.08.08

And this is my formula for the ID field:

Screenshot 2020-02-06 at 11.14.46

Anyone know a way to fix this?

1 Solution

Accepted Solutions
Jeremy_Oglesby
14 - Jupiter
14 - Jupiter

@NHAD_Team

You just need to wrap the reference to {Amount Outstanding} in the ID field formula in a ROUND() statement.

...
"- £", ROUND({Amount Outstanding}, 2), "- "
...

See Solution in Thread

3 Replies 3
Zollie
10 - Mercury
10 - Mercury

I haven’t been able to recreate your error yet. I had a very similar setup to what you described, but I wasn’t using a roll-up field. In any case, it seems your formula is losing the precision settings outlined in previous fields.

You might have some luck rounding Amount Outstanding in the ID field’s formula. See the round functions in the numeric section. They all let you specify precision.

Jeremy_Oglesby
14 - Jupiter
14 - Jupiter

@NHAD_Team

You just need to wrap the reference to {Amount Outstanding} in the ID field formula in a ROUND() statement.

...
"- £", ROUND({Amount Outstanding}, 2), "- "
...
NHAD_Team
5 - Automation Enthusiast
5 - Automation Enthusiast

@Zollie @Jeremy_Oglesby You guys are awesome. Thank you!