Help

DATEADD Formula Returning Wrong Year, but everything else is correct.

736 3
cancel
Showing results for 
Search instead for 
Did you mean: 
kbryant1144
4 - Data Explorer
4 - Data Explorer

Hello, I"m building an Airtable Template to recreate a table with the same Event tasks for each new event. We want to use logic like we had in Asana, that let's us say do XYZ task 30 days before Event Start Date.  I am using a DATEADD Foruma to produce this, and it's returning the wrong YEAR, but Month and Day is correct.

This is the formula.

DATEADD({Event Start Date},{SetupDays},"d")
 
Error below, where it's displaying the year 2001, instead of 2024.
3 Replies 3

That’s weird. Have you tried using a rollup instead of a lookup? Try the rollup formula MAX(values)

kbryant1144
4 - Data Explorer
4 - Data Explorer

I tried just plugging a date directly into the Recurring Tasks Tab, and although that fixed the formula error, it's not what I'm looking for. I'm looking to create a 'template' of tasks, and need the lookup to pull in a date from our list of tradeshows. Is there another way to fix the formula year issue?

A roll-up can pull info from a linked record the same way as lookup can. But roll ups behave differently in formulas.