App Block Cycles and Never Appears

Topic Labels: Extensions
1421 6
Showing results for 
Search instead for 
Did you mean: 
6 - Interface Innovator
6 - Interface Innovator

I’m having problems with the pre-created script app to convert URLs to attachments. It worked great this morning, but I went to run it again and the entire script has been stripped to the “Hello World” state. I’ve been trying to re-add it for hours now and if I’m lucky it just leaves me with the infinite spinning loop. If I’m SOL I get the “This page is not responding” popup. I’m used to the latter, as one of the other app blocks does this, but with enough “wait” clicks and patience I can usually get the block to start working (it’s the app to link records, if anyone is curious.)

My computer is up to date (I just checked) and I use Edge on a Windows desktop. I also use another computer which is having the same experience. Same set up.

Does anyone have any recommendations?


6 Replies 6

Script issues are very difficult to diagnose without seeing screen captures or code.

Did you have to make changes to the script to adapt it to your base? Are you having trouble re-creating those changes? Was this a free script that you found on the internet, or a script that you purchased?

I am using a script pre-made from the Airtable script library, which means I didn’t have to change any code, as the questions at the beginning set the relevant information for me (so cool!)

And the frustrating part is I’m not having error code spit back at me. I could start troubleshooting if I did.

What I am getting is the endless circle of death, where the Airtable circle just spins forever, or I get the basic “This page is not responsing” popup from Edge (and I checked Chrome too, which gave the same error.)

On the chance I hit the refresh button whatever code that URL to attachement script originally came with is deleted and I get the “Hello World” script intro. I would have tried copying it for re-use otherwise.

Thanks for helping!

Are you trying to use this script?

How many records are in your view now versus when you first tested the script? If you have many more records now, that could be the source of the problem.

I took a look at that script, and there are some rather strange things going on in the code of that script. Several lines appear to be out of order, which would make the script take a very long time if there are many records. If you have multiple attachments in a single record, you may also get unusual results.

You can also get attachment urls using a formula field. If you have only one attachment per record, you can use my app Ready Made Formulas to easily create the formula for the url of the first attachment. (If you want urls for multiple attachments per record, that can also be done in a formula field, depending on the complexity of the file names, but the app does not handle that situation, as the formula would be overly complex if you did not have special characters in file names.)

Yes, that would be the script in question. The funny thing is that I had 2.7k records, each with a single url, and it did the entire table in less than 30 seconds. It was glorious. (I thought it would be on my computer’s background processes for half of my work day.)

However, when I filtered out the few remaining records that were missing attachements (11 records) that was when everything went pear shaped. Go figure.

I will check out your app in the morning, as I’m sure it will work great, and as its a simple 1:1 I won’t need to do anything fancy to it. Thanks for the help!

Scripts can be blazing fast when they work.

The current script on the marketplace should work in your situation, but I would expect it to be extremely slow with 2.7k records, as the script is submitting each update request for each record individually. Thirty seconds seems closer to the proper time for 2.7k records if the script had been written with the lines in proper order to perform batch updates. (E.g. with the lines in the proper order, the script would be 50 times faster.)

I suspect there was something else going on that was causing the delay when you re-installed the script. My first guess is that the original script had been edited and was not the exact same script that you re-installed. Other possibilities are that there were connectivity issues when you ran the script and it never completed.

6 - Interface Innovator
6 - Interface Innovator

It took me a while to figure this out, but I was not running into connectivity issues so much as processing power issues. Once I fixed that I stopped having problems.

Thanks again for the help @kuovonne!