App not working on old phone anymore

648 6
Showing results for 
Search instead for 
Did you mean: 
5 - Automation Enthusiast
5 - Automation Enthusiast

I suddenly am not able to use the app on my old phone (Samsung S4) even though it has Android 5.01 on it (it wont update to any newer version). its been fine for about 8 months, but today it wouldn’t show normal updates, and when i tried to do a reinstall, it says it cant run on my device.

I understand this phone is obsolete, but its been very useful in my production environment to have this old phone to do production time tracking without tying up my regular phone or laptop which would be too inconvenient

I also tried to run Airtable from Chrome, but it wont activate, sends me a magic link that is only applicable on a laptop or desktop.

any work around? thanks

6 Replies 6

This support page says that the mobile app should work on Android 5.0+. However the page may be out of date. I suggest you contact Airtable support directly for more information, and cite the webpage.

If the OS is no longer supported, there isn’t much you can do about it. I had a similar situation where I was using Airtable on an old iPhone. Eventually it stopped working because the iOS was too old.

@John_Walter I don’t have an Android phone, but on iOS, you can request a desktop website in mobile Safari. If there’s a similar option in mobile Chrome on Android, that you can bypass the magic link by requesting the desktop version of the site. However, note that with the desktop version of the site, you might not be able to scroll properly nor use all of Airtable’s functions within a mobile browser.

thanks, i tried to get a chrome browser window open with the website, but it says to either send a magic link for laptop or desktop (which doesn’t want to open on a mobile phone or tablet), or open up in Android App.

thanks, i understand re the OS version. My old phone will not update to any new android, even though i tried, perhaps because it cant handle it. Might be that 5.01 is even too old for the app, even though it does say 5+ on the app store.

it also did not return the app when i searched for it directly with Google Play (again, it used to be installed and working), and when i found a link from the website, that’s when it said it wouldn’t run on my device.

oh well.

Like I said above in my previous post, you can get Airtable to work (with limitations) on Chrome for Android if you request the desktop website. Here’s how you request the desktop website:

5 - Automation Enthusiast
5 - Automation Enthusiast

thanks, I am able to get the website and see my tables, still having trouble actually seeing the data, all it shows is the list of tables and nothing else (plus its really small). I will try this with my Galaxy S10 to see if theres still a device incompatibility, and/or find out what else I’m missing. Will get back in a day or so with results.