Help

CSV Import not remembering Column 1, 2, etc. mapping

Topic Labels: Extensions
664 2
cancel
Showing results for 
Search instead for 
Did you mean: 
Sonia_
5 - Automation Enthusiast
5 - Automation Enthusiast

Hello!

I'm having an issue where the CSV Import extension doesn't remember the columns I match. I’m skipping the option “First row of CSV file is headers” since I want to use “Column 1”, “Column 2”, etc. function to match them. This is because they’re easier to identify and I can't use headers since some headers of my CSV files are blank (and I need those columns to import), so using "Column 1" and so on is easier to identify.

Once I configure this and upload one CSV, it uploads the information just fine. However, upon uploading another CSV, the tool won't remember the matching of the columns. What could be causing this?

2 Replies 2
ScottWorld
18 - Pluto
18 - Pluto

My guess is that it’s probably because you turned off the headers.

However, Airtable’s CSV import is pretty underpowered. To get the bulletproof automated CSV import that you’re looking for, I would highly recommend automating your CSV imports with Make, which offers great CSV tools.

I discuss importing and exporting CSV files with Make on this episode of the BuiltOnAir podcast

Sho
11 - Venus
11 - Venus

 

Hi @Sonia_ 

CSV import extension needs to manually set up the columns each time there is no header.

Airtable's built-in CSV importer will try to import in the order of the primary view (the top view in the list) if there are no headers, so matching the order of the fields with the order of the data in the CSV should make the import go smoothly.
However, Airtable's built-in importer does not have functions such as merging.Screenshot 2023-09-16 103355.png