Error on extension submit proccess

Topic Labels: Extensions
1259 2
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer

Hi everyone! We are having some troubles to submit our extension. We are having this error message when try ‘block submit’:

Packaging… Incomplete
Error: Dependencies cannot be on multiple disks.
Code: submitCommandWindowsMultipleDisks

Any hint or solution there? Thanks in advance

2 Replies 2
4 - Data Explorer
4 - Data Explorer

I also faced this issue when I was trying to submit my airtable extension. It was quiet hard to figure out as the error message is insufficient.
For me the issue was Windows OS. I tried cloning the project in my Linux machine and it worked.
You can also try this. Wish you luck

6 - Interface Innovator
6 - Interface Innovator

I also had the same issue. The solution was to clone the project directory to C drive, then run npm install again.

I am guessing that the SDK is trying to package both the dependencies in your project directory and also global ones in C drive, hence the error message.