Help

Upcoming database upgrades. Airtable functionality will be reduced for ~15 minutes at 06:00 UTC on Feb. 4 / 10:00 pm PT on Feb. 3. Learn more here

Manually sorting in grid view won't stay sorted

478 2
cancel
Showing results for 
Search instead for 
Did you mean: 

Probably a novice queston, but I am unable to entries in a grid view sorted after putting them in order manually; once I close and reopen the base, everything will default to alphabetical. When I switch the alphabetical sort on and off, it reverts back only partially; if I put things in a specific order manually, it won’t go back to the way I left it. Any advice on what I may be doing wrong, or how to work around this?

2 Replies 2

is this a base you’ve made, or a view that’s been shared with you? You can’t permanently adjust the sort/filter settings of a view you only have read-access to.

There’s also a keep sorted option in the sorting dialog box that should keep things in the right order, assuming you have write-access.

Hi community,

I have a problem in the same sphere ...

In a grid view, a table is sorted manually. After each opening, nevertheless, the order is kept.

But a script fetches the records of the table, and delivers them in alphabetical order, not in the manual order.

Even with no sort added - like 'sorts: [ {field: "someField"} ]' - The records are fetched in alphabetical order.

I cannot figure out a handy workaround.

Thanks in advance if you can let me know how i can workaround this behavior.