Scripting App Error "L: Linked RecordIds"

Topic Labels: Extensions
2895 10
Showing results for 
Search instead for 
Did you mean: 
6 - Interface Innovator
6 - Interface Innovator

Today my scripting app stopped working and is now giving an error.

“L: linkedRecordIds”

The issue is when pulling in records. I tried creating a separate scripting app with these three lines:

let table = base.getTable('Products');
let query = await table.selectRecordsAsync();

I am still getting the same error. Is there something wrong with the table itself? It seems any table with records that are linked to Programs give the same error while tables that aren’t are completely fine.

10 Replies 10

Welcome to the Airtable community!

The three lines of code that you posted look fine to me. They also run without error for me after changing the name of the table to match one in my base.

What is going on in the rest of the code?

Have there been any code changes or base design changes since the code was working?

7 - App Architect
7 - App Architect


I’ve been running a scripting app on one of my bases for months now with no issues, no changes. But within the past couple hours have had this issue pop up with a couple of my apps now.

Hoping that this is just a bug and gets fixed soon.

It was running fine and without issue this morning. I think a few new records may have been added to the table since. Maybe I will do a snapshot restore and see if my code works on a older version again so I can maybe pinpoint the new records causing issues. I wish the error was a little more verbose so I could know what might be causing the issue!

Thanks for testing the code. This is like the most basic example code so I was confused when that was the part of my script giving an error.

Oh very interesting. Maybe it is an error on their end. Thanks for the info!

No problem. Was just about to make a post on here as well regarding the same issue and error within my script.

I created a script in my base like this:

var table = base.getTable("Table");
var query = await table.selectRecordsAsync();

with just those two lines, I still got the error “L: linkedRecordIds” error.

I am having the same issue. The error is on the line with selectRecordsAsync() and it happens whether its a table or a view of a table.

I am able to reproduce the error with a table with a lookup field.
Do you have lookup fields in these tables?

This morning someone reported an under-the-hood issue with lookup fields. Maybe this is related.

Thanks for digging into it!

It could be related, I know my tables where these scripting apps are failing have lookups.

7 - App Architect
7 - App Architect

Hey all,

Thanks for reporting this issue and apologies for any inconvenience this might have caused. We’ve identified the issue (it was related to lookup fields as mentioned in this thread) and the fix should be fully rolled out. Let us know if you’re still experiencing any issues!