Help

WhatsApp fails when sending data from Long text field, but not normal text field

Topic Labels: Data
193 1
cancel
Showing results for 
Search instead for 
Did you mean: 
Bryan_Douglas-1
4 - Data Explorer
4 - Data Explorer

I've got an automation in Airtable to send a record ID to Make to then fetch some data and send a whatsapp message. 
When I send the content of a 'Long text field' - it fails. 
I've tried adding a function in Make to remove all special characters like line feeds etc. and send to WhatsApp - but I can't get it right. 

Anybody know what special characters are used or the regex I could use?

In my trouble-shooting, I created a single line text field and copied the text in there - then use that to send to whatsapp - and it works...  just without the line breaks. 

Any ideas for me please? 

1 Reply 1
ScottWorld
18 - Pluto
18 - Pluto

Do you have rich text formatting turned on for your long text field in Airtable? If you turn it off, does it work then?

If you need to keep rich text formatting turned on (or if it still doesn’t work after you turn it off), the problem is likely caused by Airtable storing long text fields in markdown format.

So I would try these steps in Make:

#1. I would use Make’s Markdown to HTML module to convert the long text field from markdown format into HTML format.

#2. Then, after the conversion, I would use Make’s stripHTML function to convert the HTML into plain text.

#3. Then, you will have plain text that you can send into the WhatsApp modules.

Try those 3 steps and let me know if it works!

p.s. I’m the top Airtable & Make expert in the community. If your company has a budget for your project and you’d like to hire an expert Airtable and Make consultant to help you with any of this, please feel free to contact me through my website: Airtable & Make consulting — ScottWorld