Adding text and image to the same field?

Hi, I’m currently testing Air Table for my company and I have a very specific requirement that I can’t find a solution for.

We want to use the Page Designer Block to create profiles for colleagues, including a graphic to display their language skills.

I can either pull in the graphic from a URL or from my table if I use an attachment field, but I only want to display the graphic if there’s a corresponding language entered. Ideally, I’d like to put both text and image in the same field in the table, and just pull them into Page Designer together.

Is this possible? Apologies if the explanation isn’t very clear, it’s the best I can do!

Hi @Stephen_Engel-Hart - you can’t have a single field that is both text and attachment. The approach I would take is to have a reference table for languages which also contains the graphic to illustrate each, e.g.:

Then, in your People table, have a link to the language and pull in the graphic as a lookup field:

Now, in page designer, you can pull in the languages (text and graphic) as needed:

JB

1 Like

Hi Jonathan, thanks for the tips, they worked almost perfectly. Just one additional question - my table displays with a grey border around each attachment. Sorry, I can’t post a screenshot, I keep getting an error that tells me I can’t post images.

In your screenshots, you don’t have the border around the flags. I’ve tried everything I can think of to remove/hide it, without any luck. Is there any way I can get rid of this?

Thanks!

Hi @Stephen_Engel-Hart - I’m really not sure how I’m not getting this! There doesn’t seem to be a “borders” setting on the image (there is a border radius, but that’s all). I can see two views of the page designer though - one with a grid and object borders and one without:

Is that what you’re seeing? I see the grid when I hover on page designer and it disappears when I move my mouse off.

JB

1 Like

Thanks, Jonathan.

image

This is what I’ve got (without the grid). I think it’s just the format of the image. Your flag fills the placeholder, so the grey border just isn’t as noticeable.

The frustrating thing is that it only appears when fetching the image in from another table via the lookup function. If I add the images into my table directly as attachments, no border in the page designer view, but that’s no good for me, as I want to link the language and level, and show the corresponding graphic. I might just have to go with the text for now.