Can’t push data with Integromat into Single Select columns anymore


#1

Hi there!

I use Integromat (thank you @Julian_Kirkness !) to feed my Airtable.
But since last week, some of my automations fail because it can’t push data into columns of type « single select ». I’ve tried many things (change the column type to multi, store the options in the column before Integromat plays, change the column type to short text), the scenario fails again & again.
The input data comes from a cell in a multi select column, my goal is to take each options to create separate records in another Airtable (that’s why I use Integromat over Zapier here).

Is anyone experiencing something similar? Or was and found a fix to it?
I can’t found what I’ve done wrong here…

Cheers!


#2

Hi Jeremy

I just set up a quick test pulling a value from a google sheet to an Airtable table - with one text field and one Single Select and it worked fine (as long as the value for the Single Select field is set up as an option in the field’s definition):

I think what you’re saying is that in the past, adding a value NOT already in the field options would add the option (as it does if you paste data into the field)?

In which case I can concur that this requires valid values.

I can see value in both approaches (allowing or not allowing invalid values) - would be nice to have as an option in Integromat. I wish Airtable and Integromat would get their act together and sort out their interface properly - Airtable really needs this tool!