Emailing records with "Render as HTML Grid" - field values are truncated!

Hey all, I’ve run into an interesting problem with AirTable. I have an automation script thats finds all records from today and emails those records with the “Render as HTML Grid” option. Some field values are truncated, and I couldn’t find a way to affect the row size or CSS rules that are causing this to happen. For example:

For example, there’s a parent <div> that wraps the table enforcing a max-width of 1000px (and overflow-x: auto!) and inside of each <td> element, there’s rules for a max-width of 250px and overflow: hidden.

Parent <div> of table:

Screen Shot 2021-04-19 at 1.49.30 PM

<td> rules:

Screen Shot 2021-04-19 at 1.43.09 PM

Since I can’t modify AirTable’s restrictive CSS, can anyone give me some recommendations on how to work around this with 3rd party apps or Zapier integrations to use for this specifically? The truncated table text is the only real problem I have here. :open_mouth:

Yah, I too have started using the “Render as HTML Grid” output for automated emails - it’s great, but is a little too limited lacking any and all ordering and formatting options needed. I struggle trying to track through the logic that’s being applied to the record listing… anyway, keen to hear what others have to say on this. On top of the grid record order, my column width needs to be addressed too as it’s a bit of a mess really.

1 Like

Welcome to the community, @Adrian_Ross!

If you scroll to the bottom of the field selection within your “Email Grid” step, there is an option to truncate or not truncate. So that should hopefully fix the truncating issue.

However, given the other unsolvable & gigantic problems with sending an email from Airtable that contains multiple records (as @Karlstens mentioned above), using Airtable to send emails is not really a viable option for anybody that I know. The sending records feature is incomplete & unusable at this time, so it’s simply not a feature that most people can even use at the current time.

I have 100% of my clients using Integromat to automate the sending of emails from Airtable that contain multiple records.

You can use Integromat’s Text Aggregator function to combine the data from multiple records into a single email. This is one of Integromat’s aggregator functions:

p.s. I would not recommend using Zapier for sending emails, as it also has major limitations (and is much pricier) compared to Integromat.

1 Like

Yah, at least for the lack of ordering functionality, we can now create a view and the grid/list will obey the record order within that list - but we absolutely need a more hands on better way for column width control when using the Render as HTML Grid option.

2 Likes

No, Airtable doesn’t obey the record order… it is just a lucky coincidence if it does. Try sorting or grouping your records… they will not get emailed in that order, nor will their order change in the email. Airtable only emails the records in alphabetical order of the Record ID, which shows how little thought Airtable put into this feature. They didn’t even TRY to put them into some sort of a useful order. They literally chose the LEAST HELPFUL WAY of sorting records that benefits no one.

Nah, I just retested my Automation that pulls data from a view, and emails the grid as HTML. It’s definitely sorting and emailing the rows in the correct order. The columns however are ordered depending on which was created first in the base however, which is absolutely a pain. But rows definitely sort;

For example, when I forget to enter in my timesheet info and I miss the bus on my End Of Week timed automation, I then have a manual automation that I can re-run anytime after I fill out my time sheets, that are then emailed.

The below view orders the rows Monday - Friday;

The below Automation pulls the data from that view, and the Sort Order is definitely as per the view - I just re-tested this with both a string column and also a date column and the row order was as expected.

1 Like

Try grouping your records by one of your fields along with sorting your records in a completely different order — Airtable won’t send the records in the order of your newly grouped/sorted order.

1 Like

Ahh, good point. So I can confirm - Sorting a View does work as expected, but it seems that if groups are created then it ignores the grouping arrangement/grouping sort.

So, if you create a view strictly for the sorting of records, it will only work with grouping disabled.

In thinking about groups, and being able to email a sorted grouped view, that would be hugely awesome - so time to email the Devs, again! :rofl:

1 Like

Oh, very interesting… thanks for helping me to figure this out. It actually DOES respect the sorting of the view, as long as you aren’t grouping your records. If you group your records, all bets are off. :man_shrugging:

HOWEVER: In order for this to work for ungrouped records, we are required to choose the option to “Find Records Based On View” (as you mentioned above). If we “Find Records By Condition”, that’s when it ridiculously sorts by Record ID. :rofl: :joy:

Would be nice if Airtable had some product manager who cared about the little details like this, instead of driving us all crazy! :crazy_face:

2 Likes

Yah, and I’m personally waiting for the Column order in the view to be obeyed, cause currently the columns are ordered as per the time that they were created, which is a real pain. I see no reason as to why the Grid View to HTML can’t render both the record order AND the column order as per the view - and also respect when Groups are in play too.

My only other request would be to have the ability to shade the Grid rows for ease of readability, with odd row being one colour and even row being another.

2 Likes

Thanks, Scott! It’s been interesting reading the rest of the thread, I’ve learned a lot!

Do you have another topic/question requesting the features you’re mentioning? I will definitely chime in & show support for that! :grin:

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.