Formula to Find a String within a Rollup via Zapier

I’ve got a table lookup step in Zapier that goes through Airtable and tried to locate a record from a dynamic ID that also resides in the Airtable’s rollup.

Here’s the formula I have now in Zapier:

Here’s the Rollup in Airtable:

I’ve tried removing the double quotes from the formula and have confirmed that I’m searching in the right table.

Why are the tests coming up without a match?

Rollups return an array, not a string. The FIND() formula function looks for the value you pass in a string, but it doesn’t know what to do with the array you are giving it ({Deals Rollup}).

You should be able to fix this easily by coercing the array into a string by just concatenating it with an empty string, like this:

FIND("....", {Deals Rollup} & "")

The & "" will force the array returned by {Deals Rollup} into behaving like a string, and thus play nicely with the FIND() function.

2 Likes

This topic was solved and automatically closed 15 days after the last reply. New replies are no longer allowed.