Re: Formula to Find a String within a Rollup via Zapier

476 0
Showing results for 
Search instead for 
Did you mean: 
5 - Automation Enthusiast
5 - Automation Enthusiast

I’ve got a table lookup step in Zapier that goes through Airtable and tried to locate a record from a dynamic ID that also resides in the Airtable’s rollup.

Here’s the formula I have now in Zapier:
Screen Shot 2020-12-18 at 3.36.48 PM

Here’s the Rollup in Airtable:
Screen Shot 2020-12-18 at 3.37.27 PM

I’ve tried removing the double quotes from the formula and have confirmed that I’m searching in the right table.

Why are the tests coming up without a match?

1 Reply 1

Rollups return an array, not a string. The FIND() formula function looks for the value you pass in a string, but it doesn’t know what to do with the array you are giving it ({Deals Rollup}).

You should be able to fix this easily by coercing the array into a string by just concatenating it with an empty string, like this:

FIND("....", {Deals Rollup} & "")

The & "" will force the array returned by {Deals Rollup} into behaving like a string, and thus play nicely with the FIND() function.