Formula was working, now it isn't

Hello! I’ve been using Airtable for a couple years. I don’t know much about formulas, but I can usually figure out what’s going on.

In one table, I have this formula to calculate ages: DATETIME_DIFF(TODAY(), Birthdate, ‘years’). Up until today, it’s worked perfectly. However, for some reason, now it’s giving me an error message. I have a different table with the same formula - it’s also giving me a brand new error message. I’ve tried switching the order DATETIME_DIFF(Birthday, TODAY(), ‘years’), and that works fine too (the age is just a negative number, not ideal). The kicker is, if I change the unit to ‘weeks’ it works no problem - I just don’t have a use for knowing ages in weeks.

Any ideas?

Hi @Abby_Malesytcki, it looks like there is a bug with this formula function. Sorry about the trouble! I can update you here when we’ve confirmed a fix, or I can also create a support ticket for you if you’d prefer. Please let me know!

Wow, this is a really weird error. I’m seeing it too. The error also appears when I replace TODAY with NOW.

Same here. I just saw it! And nothing else is working. :thinking:

@Jason My vote is to see an update here. Looks like it’s still a problem.

I wonder if automations are failing due to this error.

I don’t have any triggers that rely on this function, but I’m sure that some users do.

Hi everyone, this bug should be fixed now. You may need to refresh your screen (or restart your app if you’re using our desktop version) to see the changes.

So sorry for the issue!

3 Likes

Thank you! Yes, it’s working again now.

Glad to hear that @Abby_Malesytcki!

This topic was solved and automatically closed 3 days after the last reply. New replies are no longer allowed.