How can I adjust this formula to not have the ERROR message appear when the field is blank


#1

Hi! Below is the formula I’m using

DATEADD({Fast Action $7K Paid},30,‘days’)

I want to prevent the “#ERROR!” message from appearing when the “Fast Action $7K Paid” box is left empty. This field won’t always be used and the error message constantly showing is a tad frustrating. What do I need to add to the above formula to ensure that when nothing is put in the “Fast Action $7K Paid” then the error message won’t show in the next box?

Thank you for any and all help!


#2

IF({Fast Action $7K Paid}=BLANK(),“Error Will Robinson”, DATEADD({Fast Action $7K Paid},30,‘days’))


#3

So that looks right and THANK YOU! But I’m now getting the message that that formula doesn’t work


#4

you have to re-type the single quotes(maybe the double as well), they get formatted as a different but similar character in the forum. (copy and paste from the forum doesn’t work as we’d like)


#5

That did it! Thank you Michael!


#6

One more question Michael as this adjustment has now caused another error. How do I adjust DATEADD to only be the date and not the time. I don’t have the option to edit it using formatting with this formula for some reason.


#7

have a look at this


#8

Thanks, I’ll have to take a deeper look at it as the adjustments I made from that support article didn’t work.


#9

put your formula into: DATETIME_FORMAT( your formula, ‘M-D-YYYY’)


#10

That unfortunately didn’t work for me either.


#11

I see it broke the way it handles the blank


#12

I could have sworn I put it in just like that! Thank you so much Michael!


#13

Sorry, need to move the DATETIME_FORMAT to surround just the DATEADD portion so you still get the correct error handling


#14

Was just coming back to ask this :slightly_smiling_face:


#15

All is now well! Thank you thank you!