Help

Re: How can I adjust this formula to not have the ERROR message appear when the field is blank

4472 0
cancel
Showing results for 
Search instead for 
Did you mean: 
Charlotte_Barne
5 - Automation Enthusiast
5 - Automation Enthusiast

Hi! Below is the formula I’m using

DATEADD({Fast Action $7K Paid},30,‘days’)

I want to prevent the “#ERROR!” message from appearing when the “Fast Action $7K Paid” box is left empty. This field won’t always be used and the error message constantly showing is a tad frustrating. What do I need to add to the above formula to ensure that when nothing is put in the “Fast Action $7K Paid” then the error message won’t show in the next box?

Thank you for any and all help!

19 Replies 19
Mike_McLaughlin
8 - Airtable Astronomer
8 - Airtable Astronomer

IF({Fast Action $7K Paid}=BLANK(),“Error Will Robinson”, DATEADD({Fast Action $7K Paid},30,‘days’))

So that looks right and THANK YOU! But I’m now getting the message that that formula doesn’t work

you have to re-type the single quotes(maybe the double as well), they get formatted as a different but similar character in the forum. (copy and paste from the forum doesn’t work as we’d like)

Charlotte_Barne
5 - Automation Enthusiast
5 - Automation Enthusiast

That did it! Thank you Michael!

Charlotte_Barne
5 - Automation Enthusiast
5 - Automation Enthusiast

One more question Michael as this adjustment has now caused another error. How do I adjust DATEADD to only be the date and not the time. I don’t have the option to edit it using formatting with this formula for some reason.

have a look at this

5f73751092c6afb3485d0dfe997b3809227f5002.png

Supported format specifiers for DATETIME_FORMAT

The DATETIME_FORMAT function will allow you to reformat the data from the date-type field into a string of your specifications. This is written in the form "DATETIME_FORMAT(Datetime, 'format s...

Thanks, I’ll have to take a deeper look at it as the adjustments I made from that support article didn’t work.

put your formula into: DATETIME_FORMAT( your formula, ‘M-D-YYYY’)

That unfortunately didn’t work for me either.