Launched: advanced formatting options for images in linked tables in page designer block

We just introduced several formatting options for when you’re displaying attachments from a linked record field in page designer block:

  • Display just the first image in the attachment field, or all
  • Size attachments as square thumbnails, with fixed height/automatic width, or with automatic height/fixed width
  • Set image size and padding

8 Likes

Wow, really nice! Great job! :smiley::raised_hands::star2:

Waw ! :star_struck:
Very interesting ! :raised_hands:
Thank you !

oLπ

I wanted to try this, however, the options do not show up for me for either previously created Page Designer blocks or new ones. Where can I find the option to toggle “Use advanced image settings”? It is nowhere to be found from what I can see.

There isn’t an option called “Use advanced image settings”. You just click on an attachment field while you are editing your page layout, and the new attachment options appear in the left margin.

If you’re still not seeing them after you click on an attachment field, try logging out & logging in again.

Since this new feature was introduced the image field grabs the LAST instead of the FIRST image. My settings set to ‘First Image’.
If I do ‘all images’ the order of them is reversed as well.
How do I fix it? Thanks!

Also, what does the Order settings do? It seems that nothing changes when I change them.
Thanks!

I don’t currently have a base set up where I can test this, and I’m out of the house on my phone at the moment, but it may be related to the option in the setup for a link field that controls the order the links appear. If your base is an older one (older than a week or two ago, off the top of my head), it may be using the legacy setting that reverses the link order by default.

My base is more than 2 years old. Everything was working fine before this new feature.
I could Have rearrange my images so the last one is what I want to see in the Page Designer BUT then in my Canban view the first image will show. So it will be wrong in one or another.
How can I fix the order in Page Designer so it actually takes the first I age, not the last?
Thank you!

You may want to contact Airtable Support about this issue. If the provided tools aren’t changing the order, then it will probably need a deeper look by the support techs.