Help

Discover what data silos are costing your org in our commissioned Forrester study. Learn more

Automation - history says it ran fine but new record not appearing

Topic Labels: Automations
Solved
Jump to Solution
396 7
cancel
Showing results for 
Search instead for 
Did you mean: 

image

I setup my first automation and it seems to have worked according to the ‘history’ but when I look in the table where it supposedly created a new record, the new records aren’t there. I don’t have any filters on, I searched and sorted in various ways with no luck, and just can’t figure out what it could be. Can anyone help? thank you!

1 Solution

Accepted Solutions

Could you have another automation that is deleting records?

What happened if you scrap this automation and rebuild it from scratch?

See Solution in Thread

7 Replies 7

Hey @Jessica_Crocker! Welcome in!

Could you do me a quick favor and retest your automation steps from the trigger?
Airtable automation can be weird about making changes to them once they’re already on, even if the changes are small.
Doing a full test through from the top can help to flush things out.


The second thing I’d like for you to do is to look at this portion of the action run history:

image

You’ll see a record ID in the run history.
This is the record ID for the record that was created as a result of the automation action.

If you click on that record ID as shown, it will pull up the expanded record that was created.

image

Let me know if that helps to resolve what’s going on.
If not, please write back and we’ll nail down what’s going on here!

How many times does the automation history say that the automation has run? How many “new” records were created?

Note that the automation will only run for records that did not match the condition when the automation was turned on, and then changed to match the condition while the automation was active. The automation will not run for other records that met the condition before the automation was turned on.

Thanks Ben - there is a record ID there but it doesn’t show as a link/ you can’t open the record and when I search for the record ID in my table (i added this as a formula field), nothing is found.

@kuovonne - the automation ran the correct number of times/ it found the exact 7 records which had been changed since I turned it on, so think that side is working ok…

image

Your screen capture shows a record url in the history of the Create Record action. What happens when you try to go to that url?

If I copy that link and paste into my browser, it just goes back to the main automations tab/ main sheet view. No record pops up. So odd!

Could you have another automation that is deleting records?

What happened if you scrap this automation and rebuild it from scratch?

Thank you! I tried building it again, exactly the same way as far as i can see and it worked great! No idea why but anyway it’s working now which is great. thanks for your help