Automation not allowing me as collaborator in field, but allowing others

Topic Labels: Automations
1776 8
Showing results for 
Search instead for 
Did you mean: 
4 - Data Explorer
4 - Data Explorer

The automation creates a new record based on criteria, one of which is a collaborator field filled in. All works fine with the appropriate collaborator filled in except my name. I’ve tried with and without quotes, copying my name directly from the field in the table, even starting from scratch, nothing works.

The collaborator field is called “Owner” and I get the following failed message: Field “Owner” cannot accept the provided value: No matching collaborator.

I appreciate any guidance. Thanks in advance.

8 Replies 8
10 - Mercury
10 - Mercury

When you manually add a collaborator to the field, do you see yourself in the list?

Hi. Thank you for your reply.

I don’t see a list. The field is set to multiple collaborators and I just added my name directly on the “Owner” field. When I add someone else, it works fine. But not my own name.

If I remove that step, the test passes.

I understand. When in the grid view, what do you see when you manually add a collaborator to {Owner}? Are you in the list of collaborators?

Yes, when it hit the + sign in the field, I’m on the list along with several other people. I can directly add it with no problem.

Sorry that I’m asking so many questions, Ali. What’s the trigger for this action? Your original post says

So, part of the trigger is that the collaborator field has a value in some record(s), and then you want to add a new record with a collaborator field called {Owner} that has your name?

Is that close or did I misunderstand? I worry that this automation might never end (logically).

Hi again, I appreciate you asking the questions.

I’m trying auto tasks for a sales lead table.

The setup is the following:

Table from Base A is synced into Base B.

Base A table is called: Company/Organizations.

Base B Automation has the three conditions: 1. look in synced table (Company/Orgs.) find field with me as “Lead Person,” 2. Stage field is “Lead” and 3. “Main Contact Field” is not empty.

Then the action is to create a new record in Base B table called Tasks. A record is to be created to follow up with the lead entered in synced table Company/Orgs. along with other info like notes and status. But along with those fields in Task table filled in, I wanted to assign “Owner” field (multiple collaborator field) to me since Base A table is looking up me as “Lead” the Task table (in Base B) needs to have me as well.

10 - Mercury
10 - Mercury

Thanks Ali. Makes sense. Only I wish I had the answer for you. I would just check a couple of things. One, that your user name is exactly the same as what you’re typing in the automation for the {Owner} field. No quotes are necessary (I think you tried it).

Second, I’ve heard of automation difficulties with collaborators if their email hasn’t been confirmed. It’s been so long since I’ve been added to an Airtable account, I don’t remember the process on Airtable’s end. I wish that I knew how to check.

If I remember anything else, I’ll post back here. Hopefully someone else will chime in, there are more experienced Airtable users than me (for sure).

Thank you very much for taking the time to make some suggestions. Most appreciated.